易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 6002|回复: 126

内存钩子防追封教程,最新防追封方法,dnf辅助易语言源码

[复制链接]
发表于 2012-6-9 11:11:42 | 显示全部楼层 |阅读模式
发表于 2013-2-19 17:33:41 | 显示全部楼层
看起来很坑爹的样子
发表于 2013-2-23 03:06:20 | 显示全部楼层
都是发生的冯绍峰
发表于 2013-2-23 20:51:47 | 显示全部楼层
真的假的阿。
发表于 2013-2-23 22:33:03 | 显示全部楼层
回复 1# 路飞


    很好很强大啊啊
发表于 2013-3-1 00:10:30 | 显示全部楼层
看看是什么回事
发表于 2013-3-6 08:22:37 | 显示全部楼层
防追封你在哪?
发表于 2013-3-6 08:34:48 | 显示全部楼层
.版本 2
.全局变量 进程ID, 整数型


.版本 2

进程ID = 进程取ID (“DNF.exe”)

.版本 2

.子程序 加密
.参数 地址, 整数型
.参数 数值, 整数型
.局部变量 地址1, 整数型
.局部变量 地址2, 整数型
.局部变量 地址3, 整数型
.局部变量 数据1, 整数型
.局部变量 数据2, 整数型
.局部变量 数据3, 整数型

地址1 = 内存_驱动读写1.读整数型 (进程ID, 内存_驱动读写1.读整数型 (进程ID, 十六到十 (#加密参数1)) + 十六到十 (“44”))
地址2 = 内存_驱动读写1.读整数型 (进程ID, 十六到十 (#加密参数2))
数据1 = 内存_驱动读写1.读整数型 (进程ID, 地址)
数据1 = 左移 (数据1, 2)
数据2 = 数据1 + 地址1
数据2 = 位异或 (数据2, 地址2)
数据3 = 位异或 (数据2, 数值)
地址3 = 数据1 + 地址1
内存_驱动读写1.写整数型 (进程ID, 地址3, 数据3)

.子程序 解密, 整数型
.参数 地址, 整数型
.局部变量 地址1, 整数型
.局部变量 地址2, 整数型
.局部变量 数据1, 整数型
.局部变量 数据2, 整数型

地址1 = 内存_驱动读写1.读整数型 (进程ID, 内存_驱动读写1.读整数型 (进程ID, 十六到十 (#加密参数1)) + 十六到十 (“44”))
地址2 = 内存_驱动读写1.读整数型 (进程ID, 十六到十 (#加密参数2))
数据1 = 内存_驱动读写1.读整数型 (进程ID, 地址)
数据1 = 左移 (数据1, 2)
数据2 = 内存_驱动读写1.读整数型 (进程ID, 数据1 + 地址1)
.如果真 (数据2 = -1)
    返回 (-1)
.如果真结束
地址1 = 数据1 + 地址1
数据2 = 位异或 (数据2, 地址1)
数据2 = 位异或 (数据2, 地址2)
返回 (数据2)



.版本 2

.子程序 SSS评分

.如果真 (内存_驱动读写1.读代码 (进程ID, #人物基址 + “+E0+10”) > 0)  
    内存_驱动读写1.写代码 (进程ID, #评分基址 + “+5C=1149239296”)



.版本 2

.子程序 加密调用方法

加密 (内存_驱动读写1.读代码 (进程ID, #基址) +十六到十(偏移) ,数值)



.版本 2

.子程序 全屏吸物
.局部变量 计次, 整数型
.局部变量 地址, 整数型
.局部变量 类型, 整数型
.局部变量 x, 整数型
.局部变量 y, 整数型

.如果真 (内存_驱动读写1.读代码 (进程ID, #人物基址 + “+E0+10”) > 0)
    .计次循环首 (50, 计次)
        计次 = 计次 × 4
        地址 = 内存_驱动读写1.读整数型 (进程ID, 内存_驱动读写1.读代码 (进程ID, #人物基址 + “+E0+90”) + 计次)
        类型 = 内存_驱动读写1.读整数型 (进程ID, 地址 + 十六到十 (“BC”))
        .如果真 (类型 = 289)
            x = 内存_驱动读写1.读小数型 (进程ID, 内存_驱动读写1.读整数型 (进程ID, 十六到十 (#人物基址)) + 十六到十 (“184”))
            y = 内存_驱动读写1.读小数型 (进程ID, 内存_驱动读写1.读整数型 (进程ID, 十六到十 (#人物基址)) + 十六到十 (“188”))
            内存_驱动读写1.写小数型 (进程ID, 内存_驱动读写1.读整数型 (进程ID, 地址 + 十六到十 (“D0”)) + 十六到十 (“C”), x)
            内存_驱动读写1.写小数型 (进程ID, 内存_驱动读写1.读整数型 (进程ID, 地址 + 十六到十 (“D0”)) + 十六到十 (“10”), y)
        .如果真结束

    .计次循环尾 ()


不掉线 不追封 不报毒(部分杀软) 不卡屏 直接写在EXE中即可使用
发表于 2013-3-7 12:57:36 | 显示全部楼层
...............看
发表于 2013-3-17 14:21:28 | 显示全部楼层
学习学习下
点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 感恩
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2018-7-21 19:30 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表