易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 176|回复: 0

易语言判断时间 易语言如何判断系统时间

[复制链接]
发表于 2017-6-17 09:07:02 | 显示全部楼层 |阅读模式
易语言如何判断系统时间
使用“如果”“取现行时间”“信息框”语句

转换为unix时间戳  就能通过大小比对判断了


.版本 2

.子程序 Unix时间戳记正转, 长整数型, 公开, 将时间类型值转到长整型的标准UNIX使用的格林威治时间戳记
.参数 时间值, 日期时间型, , 要转换的时间值
.参数 是否为秒, 逻辑型, 可空, 设置返回的时间戳记值单位 真:秒  假:毫秒   默认为真
.参数 是否为北京时间, 逻辑型, 可空, 默认为真
.局部变量 初始时间, 日期时间型

.如果真 (是否为空 (是否为北京时间))
    是否为北京时间 = 真
.如果真结束
.如果 (是否为北京时间)
    初始时间 = 到时间 (“1970-01-01 08:00:00”)
.否则
    初始时间 = 到时间 (“1970-01-01 00:00:00”)
.如果结束
.如果真 (是否为空 (是否为秒))
    是否为秒 = 真
.如果真结束
.如果 (是否为秒)
    返回 (取时间间隔 (时间值, 初始时间, #秒))
.否则
    返回 (取时间间隔 (时间值, 初始时间, #秒) × 1000)
.如果结束
返回 (取时间间隔 (时间值, 初始时间, #秒))

.子程序 Unix时间戳记反转, 日期时间型, 公开, 将标准UNIX使用的格林威治时间戳记转到易系统时间日期格式
.参数 时间戳记值, 长整数型, , 要转换的时间戳记值
.参数 是否为秒, 逻辑型, 可空, 时间戳记值单位 真:秒  假:毫秒   默认为真
.参数 是否为北京时间, 逻辑型, 可空, 默认为真,
.局部变量 初始时间, 日期时间型

.如果真 (是否为空 (是否为北京时间))
    是否为北京时间 = 真
.如果真结束
.如果 (是否为北京时间)
    初始时间 = 到时间 (“1970-01-01 08:00:00”)
.否则
    初始时间 = 到时间 (“1970-01-01 00:00:00”)
.如果结束
.如果真 (是否为空 (是否为秒))
    是否为秒 = 真
.如果真结束
.如果 (是否为秒)
    返回 (增减时间 (初始时间, #秒, 时间戳记值))
.否则
    返回 (增减时间 (初始时间, #秒, 时间戳记值 ÷ 1000))
.如果结束
返回 (增减时间 (初始时间, #秒, 时间戳记值))
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-10-22 14:30 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表