易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 132|回复: 0

易语言 读入一行 易语言怎么一行一行的读取TXT文本

[复制链接]
发表于 2017-6-17 08:39:21 | 显示全部楼层 |阅读模式
.版本 2
.支持库 spec
.局部变量 temp, 文本型
.局部变量 数组, 文本型, , "0"
.局部变量 n1, 整数型
temp = 到文本 (读入文件 (取运行目录 () + “\123.txt”))
数组 = 分割文本 (temp, #换行符, )
.计次循环首 (取数组成员数 (数组), n1)
    调试输出 (数组 [n1])
.计次循环尾 ()

或者

画一个编辑框和一个时钟 编辑框可以改允许多行,,,  帮你简单的写几句 当然实现你要的效果方法有很多的 把虚线里代码全部复制到编程区试运行下看是不是你想要的,,,,,
=============================================================
.版本 2
.程序集 窗口程序集1
.程序集变量 文件号, 整数型
.子程序 __启动窗口_创建完毕
文件号 = 打开文件 (“文件路径”, 1, )
移到文件首 (文件号)
_时钟1_周期事件 ()
.子程序 _时钟1_周期事件
编辑框1.内容 = 读入一行 (文件号)

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-8-21 03:17 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表