易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 165|回复: 0

易语言验证代理 易语言如何开启多线程验证代理IP 验证代理IP原理

[复制链接]
发表于 2017-6-16 08:48:49 | 显示全部楼层 |阅读模式

验证代理IP原理

我来提供一个思路,不一定好用..
你好像用http来代表一个IP去访问百度或一个网站...如果能返回正确的内容就是能代理.反之就是不能代理.


=======================

你可以用http来代理IP访问一个IP去访问百度或一个网站...如果能返回正确的内容就是能代理.反之就是不能代理.


.版本 2
.支持库 spec

.子程序 __启动窗口_创建完毕

调试输出 (到文本 (访问网页_XmlHttp (“http://www.baidu.com”, “122.224.249.204:8080”)))
.如果 (寻找文本 (到文本 (访问网页_XmlHttp (“http://www.baidu.com”, “122.224.249.204:8080”)), “<!DOCTYPE html><!--STATUS OK--><html>”, , 假) ≠ -1)
    调试输出 (“代理可用”)
.否则
    调试输出 (“代理不可用”)
.如果结束


.子程序 访问网页_XmlHttp, 字节集, 公开, get一个网站
.参数 完整网址, 文本型, , 完整网址
.参数 代理地址, 文本型, 可空, 代理地址
.局部变量 XMLHTTP, 对象
.局部变量 局部_返回数据, 字节集

CoInitialize (0)  ' 初始化对象开始
.如果真 (XMLHTTP.创建 (“WinHttp.WinHttpRequest.5.1”, ))
    XMLHTTP.方法 (“setProxy”, 2, 代理地址)
    XMLHTTP.方法 (“open”, “GET”, 完整网址, 假, )
    XMLHTTP.方法 (“setRequestHeader”, “Referrer”, 完整网址)  ' 仅服务器可知 来路
    XMLHTTP.方法 (“setRequestHeader”, “Accept”, “image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/x-shockwave-flash, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*”)
    XMLHTTP.方法 (“setRequestHeader”, “Accept-Language”, “zh-cn”)
    XMLHTTP.方法 (“setRequestHeader”, “Content-Type”, “application/x-www-form-urlencoded”)
    XMLHTTP.方法 (“setTimeouts”, 15000, 15000, 15000, 15000)  ' 超时
    XMLHTTP.方法 (“send”, )
    局部_返回数据 = XMLHTTP.读属性 (“responseBody”, ).取字节集 ()
.如果真结束
CoUninitialize ()  ' 初始化对象结束
返回 (局部_返回数据)
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-8-21 03:17 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表