易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 207|回复: 1

易语言取日期 易语言怎么取日期

[复制链接]
发表于 2017-6-15 08:57:01 | 显示全部楼层 |阅读模式

.版本 2
.支持库 internet
.支持库 spec

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕
.局部变量 时间文本, 文本型, , "0"

文本_取中间_批量_正则方式 (到文本 (HTTP读文件 (“ http://www.beijing-time.org/time.asp”)), “=”, “;”, 时间文本, , 4)
调试输出 (时间文本 [1] + “-” + 取文本右边 (“0” + 时间文本 [2], 2) + “-” + 取文本右边 (“0” + 时间文本 [3], 2))


===============

.版本 2
.支持库 spec

.子程序 __启动窗口_创建完毕

调试输出 (取日期 ())

.子程序 取日期, 文本型
.局部变量 年, 文本型
.局部变量 月, 文本型
.局部变量 日, 文本型

年 = 到文本 (取年份 (取现行时间 ()))
月 = 到文本 (取月份 (取现行时间 ()))
日 = 到文本 (取日 (取现行时间 ()))
返回 (年 + “年” + 月 + “月” + 日 + “日”)


=========

只会笨方法
.版本 2
.支持库 spec

调试输出 (取日期 (取现行时间 ()))
调试输出 (到文本 (取年份 (取现行时间 ())) + “-” + 到文本 (取月份 (取现行时间 ())) + “-” + 到文本 (取日 (取现行时间 ())))

点评

海!外*** t.cn/RxlBL8D 禁闻视频 t.cn/RJAQKcb 人们对斯大林的评价:一个连言论都能治罪的政权,不要去相信它的任何宣传;一个连良心都能判刑的政权,不要去相信它的任何口号;一个枪口能对准平民的政权,不要去相信它的   发表于 前天 21:34
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-12-13 03:49 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表