易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 1578|回复: 2

[易求助] 求助,大神帮帮忙,关于DNF辅助

[复制链接]
发表于 2017-2-20 23:08:22 | 显示全部楼层 |阅读模式
10流星币
大神看看那里错了,为什么不全屏攻击 不锁定怪物,就在头上劈


.版本 2

.子程序 _全屏技能_周期事件
.局部变量 怪物数量, 整数型
.局部变量 尾地址, 整数型
.局部变量 首地址, 整数型
.局部变量 二级偏移, 整数型
.局部变量 一级偏移, 整数型
.局部变量 ice, 整数型
.局部变量 怪物地址, 整数型
.局部变量 怪物类型, 整数型
.局部变量 怪物阵营, 整数型
.局部变量 怪物X, 整数型
.局部变量 怪物Z, 整数型
.局部变量 怪物Y, 整数型
.局部变量 人物X, 整数型
.局部变量 人物Y, 整数型
.局部变量 人物Z, 整数型
.局部变量 数量, 整数型
.局部变量 触发基址, 整数型

触发基址 = 十六到十 (#人物基址)
.如果真 (触发基址 = 0)
    返回 ()
.如果真结束
一级偏移 = 读内存整数型 (进程ID, 触发基址)
二级偏移 = 读内存整数型 (进程ID, 一级偏移 + 十六到十 (#地图二级偏移))
首地址 = 读内存整数型 (进程ID, 二级偏移 + 十六到十 (#地图首))
尾地址 = 读内存整数型 (进程ID, 二级偏移 + 十六到十 (#地图尾))
怪物数量 = (尾地址 - 首地址) ÷ 4
.计次循环首 (怪物数量, ice)
    怪物地址 = 读内存整数型 (进程ID, 首地址 + 4 × ice)
    怪物类型 = 读内存整数型 (进程ID, 怪物地址 + 十六到十 (#类型))
    怪物阵营 = 读内存整数型 (进程ID, 怪物地址 + 十六到十 (#阵营))
    怪物X = 读内存小数型 (进程ID, 怪物地址 + 十六到十 (#X轴))
    怪物Z = 读内存小数型 (进程ID, 怪物地址 + 十六到十 (#Z轴))
    怪物Y = 读内存小数型 (进程ID, 怪物地址 + 十六到十 (#Y轴))
    人物X = 读内存小数型 (进程ID, 一级偏移 + 十六到十 (#X轴))
    人物Z = 读内存小数型 (进程ID, 一级偏移 + 十六到十 (#Z轴))
    人物Y = 读内存小数型 (进程ID, 一级偏移 + 十六到十 (#Y轴))

    .如果真 (怪物类型 = 529 或 怪物类型 = 273)
        .如果真 (怪物阵营 = 100 或 怪物阵营 = 101 或 怪物阵营 = 110 或 怪物阵营 = 50 或 怪物阵营 = 120)
            .如果真 (怪物地址 ≠ 一级偏移)
                数量 = 数量 + 1
                技能CALL (99999999, 到整数 (_启动窗口.代码框.内容), 0, 0, 0)
            .如果真结束

        .如果真结束

    .如果真结束

.计次循环尾 ()

.版本 2

.子程序 技能CALL
.参数 伤害, 整数型
.参数 代码, 整数型
.参数 X, 整数型
.参数 Y, 整数型
.参数 Z, 整数型

置汇编代码 ({  })
清空汇编代码 ()
Pushad ()
Mov_ESI_Ptr (十六到十 (#人物基址))
Push (0)
Push (0)
Push (0)
Mov_ECX_Ptr (十六到十 (#技能參數1))
Push_ECX ()
Mov_ECX_Ptr (十六到十 (#技能參數2))
Push_ECX ()
Push (0)
Push (4)
Push (Z)
Push (Y)
Push (X)
Push (0)
Push (0)
Push (伤害)
Push (代码)
Mov_ECX_ESI ()
Mov_EDX (十六到十 (“0086DDB0”))
Call_EDX ()
Popad ()
ret ()
开始Virus (进程ID)
汇编远程执行 (取汇编代码 ())
结束Virus ()

.版本 2

.子程序 全屏攻击

.如果 (全屏技能.时钟周期 = 0)
    全屏技能.时钟周期 = 400
    公告 (“F4技能攻击 开启”)
.否则
    全屏技能.时钟周期 = 0
    公告 (“F4技能攻击 关闭”)
.如果结束



发表于 2017-3-11 15:15:02 | 显示全部楼层
技能CALL (99999999, 到整数 (_启动窗口.代码框.内容), 怪物坐标x, 怪物坐标y, 怪物坐标z)
发表于 2017-4-8 23:50:30 | 显示全部楼层
坐标轴不对吧
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-11-24 09:50 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表