易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 517|回复: 2

易语言DLL注入游戏后无法完全御载,肿么办

[复制链接]
发表于 2014-3-9 08:41:30 | 显示全部楼层 |阅读模式
新手求解
易语言DLL注入游戏后无法完全御载,点御载后只是DLL界面图标和被入注的游戏图标不一样了,用注入工具看DLL还在   

计算器做小白鼠,代码:

.版本 2
.支持库 shell

.程序集 窗口程序集1
.程序集变量 输入法句柄, 整数型

.子程序 __启动窗口_创建完毕

热键.注册 (_启动窗口.取窗口句柄 (), , #Home键, &激活进程)

.子程序 输入法注入DLL

写到文件 (取特定目录 (10) + “\SouGou.ime”, #输入法文件SouGou)
输入法句柄 = 输入法.安装 (取特定目录 (10) + “\SouGou.ime”, “SG输入法”)
.如果真 (输入法句柄 ≠ 0)
    输入法.设置注入 (取特定目录 (10) + “\SouGou.ime”, 取运行目录 () + “\GameCheat1.dll”)
    信息框 (“按Home键呼出!”, 0, )
.如果真结束


.子程序 _按钮1_被单击

.判断开始 (进程是否存在 (“calc.exe”))
    输入法注入DLL ()
.默认
    信息框 (“未运行游戏!”, 0, )
.判断结束


.子程序 激活进程

.判断开始 (进程是否存在 (“calc.exe”))
    输入法.激活 (取句柄 (“calc.exe”, , ), 输入法句柄)
.默认

.判断结束


.子程序 _按钮2_被单击

.如果 (输入法.卸载 (输入法句柄) = 真)
    输入法.清除注入 (取特定目录 (10) + “\SouGou.ime”)
    信息框 (“关闭成功!”, 0, )
.否则
    信息框 (“关闭失败!可能已经关闭!”, 0, )
.如果结束


.子程序 __启动窗口_将被销毁

输入法.清除注入 (取特定目录 (10) + “\SouGou.ime”)
输入法.卸载 (输入法句柄)
销毁 ()



DLL代码:

.版本 2

.子程序 _启动子程序, 整数型, 公开, 请在本子程序中放置动态链接库初始化代码

载入 (控制台窗口, , 假)
返回 (0)  ' 返回值被忽略。

.子程序 _临时子程序

' 本名称子程序用作测试程序用,仅在开发及调试环境中有效,编译发布程序前将被系统自动清空,请将所有用作测试的临时代码放在本子程序中。 ***注意不要修改本子程序的名称、参数及返回值类型。
发表于 2019-1-8 18:29:56 | 显示全部楼层
看看学习下。。。
发表于 6 天前 | 显示全部楼层
初来乍到,认真回复
点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 感恩
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区 |网站地图

GMT+8, 2019-1-22 07:08

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表