易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 74600|回复: 1309

DNF辅助稳定源码(全功能版)

  [复制链接]
发表于 2013-1-25 09:39:23 | 显示全部楼层 |阅读模式
发表于 2014-11-25 21:12:35 | 显示全部楼层
0.000水碎  水
发表于 2014-11-25 21:55:21 | 显示全部楼层
来研究研究
发表于 2014-11-25 22:08:11 | 显示全部楼层
卡在提升进程权限 这里
发表于 2014-11-29 10:33:40 | 显示全部楼层
倒萨的还是嘎哈的嘎斯
发表于 2014-11-29 18:51:21 | 显示全部楼层
.........................................
发表于 2014-11-30 22:48:50 | 显示全部楼层
学习一下啊
发表于 2014-12-1 01:18:42 | 显示全部楼层
学习一下。
发表于 2014-12-1 06:51:17 | 显示全部楼层
好东西好东西好东西
发表于 2014-12-1 06:52:14 | 显示全部楼层
好东西好东西好东西
发表于 2014-12-2 20:03:19 | 显示全部楼层
额外全球俄武器恶趣味
发表于 2014-12-4 20:52:33 | 显示全部楼层
研究一下谢谢了
发表于 2014-12-7 11:09:06 | 显示全部楼层
回复 1# 清淡小女子


        研究研究哈
发表于 2014-12-7 21:02:48 | 显示全部楼层
子程序 进图CALL, , 公开
.参数 区域id, 整数型, , 3-塔
.参数 位置id, 整数型, , 7-塔
.局部变量 c1, 整数型
.局部变量 c2, 整数型
.局部变量 c3, 整数型
.局部变量 loc1, 整数型
.局部变量 ebp_14, 整数型

c1 = 十六到十 (搜索_X轴参数 ()) ' 0128 X轴参数十进制
c2 = 十六到十 (搜索_Y轴参数 ()) ' 0128 Y轴参数十进制
c3 = 十六到十 (搜索_Z轴参数 ()) ' 0128 Z轴参数十进制
loc1 = 0
ebp_14 = 十六到十 (搜索_城镇参数 ()) ' 0128 头部参数

置入代码 ({ 139, 77, 236, 139, 9 }) ' ecx
置入代码 ({ 106, 15, 255, 85, 252 }) ' 0x26是城内移动;0x7是返回角色 0x0f是打开选图 0x2D是回城

loc1 = 3 ' 区域[1=埃尔文防线,2=赫尔马顿,3=西海岸,4=阿法利亚,5=斯顿雪域,6=根特,7=末日之都,8=仓库?]
置入代码 ({ 139, 77, 236, 139, 9 }) ' ecx
置入代码 ({ 106, 1, 141, 85, 240, 82, 255, 85, 248 }) ' 1字节

loc1 = 7 ' 区域中的位置。6在格兰就是进副本那。就是区域中的小区域。7是西海岸的塔 遗迹门口(4,3),雪域门口(5,2)
置入代码 ({ 139, 77, 236, 139, 9 }) ' ecx
置入代码 ({ 106, 1, 141, 85, 240, 82, 255, 85, 248 }) ' 1字节

loc1 = 120 ' 450 120
置入代码 ({ 139, 77, 236, 139, 9 }) ' ecx
置入代码 ({ 106, 2, 141, 85, 240, 82, 255, 85, 248 }) ' 2字节

loc1 = 300 ' 350 300
置入代码 ({ 139, 77, 236, 139, 9 }) ' ecx
置入代码 ({ 106, 2, 141, 85, 240, 82, 255, 85, 248 }) ' 2字节

loc1 = 5 ' z? 5这个没什么效果,不知道是不 是 Z 轴,注意是1字节。反正游戏里都是5。
置入代码 ({ 139, 77, 236, 139, 9 }) ' ecx
置入代码 ({ 106, 1, 141, 85, 240, 82, 255, 85, 248 }) ' 1字节
置入代码 ({ 255, 85, 244 }) ' send

.子程序 扩大范围CALL, , 公开
.参数 基址, 整数型
.参数 伤害12345, 整数型
.参数 技能, 整数型
.局部变量 代码12345, 字节集

置汇编代码({ })
Pushad ()
Mov_ESI_Ptr (基址)
Push (0)
Push (0)
Mov_ECX_ESI ()
Mov_EDX_Ptr_ECX_Add (0)
Mov_EAX_EDX ()
Add_EAX (十六到十 (到文本 (“320”))) ' 原本30C
Mov_EBX_Ptr_EAX_Add (0)
Mov_EAX_Ptr (十六到十 (搜索_技能参数1 ())) ' 技能1
Mov_ECX_Ptr (十六到十 (搜索_技能参数2 ())) ' 技能2
Push_EAX ()
Push (1000) ' 这里写0范围不变 写1000扩大
Push (0)
Push (4)
Push (0)
Push (0)
Push (0)
Push (0)
Push (0)
Push (到数值 (伤害12345)) ' 伤害
Push (到数值 (技能)) ' 代码
Mov_ECX_ESI ()
Call_EBX ()
发表于 2014-12-7 21:16:40 | 显示全部楼层
来学习学习先的
发表于 2014-12-7 22:48:59 | 显示全部楼层
DNF是值得学习的哦
发表于 2014-12-8 04:46:01 | 显示全部楼层
.版本 2

.常量 rw, "17283344"
.常量 坐标一级, "260"
.常量 鼠标Y偏移, "272"
.常量 鼠标X偏移, "276"
.常量 枪击Y偏移, "284"
.常量 枪击X偏移, "288"
.常量 是否死亡偏移, "1032"
.常量 本人死亡基址, "17283336"
.常量 阵营基址, "17339876"
.常量 敌人基址, "17345124"
.常量 模式基址, "17392664"
.常量 模式一级, "12"
.常量 模式二级, "288"
.常量 本人位置, "17345096"
.常量 坐标X偏移, "320"
.常量 坐标Z偏移, "324"
.常量 坐标Y偏移, "328"
.常量 是否在游戏基址, "17225130"
.常量 视角基址, "17392676"
.常量 视角偏移, "44"
.常量 是否为生化, "11772"
.常量 团队模式, "0"
.常量 爆破模式, "1"
.常量 幽灵模式, "2"
.常量 歼灭模式, "3"
.常量 个人竞技, "4"
.常量 特殊站, "5"
.常量 突围模式, "6"
.常量 挑战, "7"
.常量 终结者模式, "8"
.常量 生化, "9"
.常量 救世主, "10"
发表于 2014-12-8 20:24:24 | 显示全部楼层
CE2573CC39A759A33AB202703BBE851
发表于 2014-12-9 00:23:25 | 显示全部楼层
咳咳咳咳咳咳咳咳咳咳咳咳
发表于 2014-12-9 13:46:43 | 显示全部楼层
2020201420202014
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-12-14 08:30 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表