易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
楼主: 没有不可能

腾讯游戏的反智辅保护来一个总结关于腾讯游戏的所有保护

[复制链接]
发表于 2013-2-6 12:55:57 | 显示全部楼层
发表于 2013-2-9 17:57:17 | 显示全部楼层
来学习的哟哈哈
发表于 2013-2-10 03:01:07 | 显示全部楼层
子程序 返回BOSS地址, 整数型
.参数 BVV, 整数型, , 529是怪物 273是APC 1057是普通建筑 33是特殊建筑
.参数 FDD, 整数型, 可空, 默认为队友,-1为不限 100为敌人 200为建筑 0为队友
.局部变量 XXC, 整数型
.局部变量 BVVC, 整数型

.判断循环首 (是否指定怪物 (内存操作.读整数 (BVVC), FDD, BVV) = 0)
    XXC = XXC + 1
    BVVC = 内存操作.读代码 (#人物基址 + “+B4+B0”) + XXC × 4
    .如果真 (XXC = 273)
        返回 (0)
    .如果真结束

.判断循环尾 ()
返回 (BVVC)

.子程序 是否指定怪物, 整数型
.参数 SDWW, 整数型
.参数 HRRE, 整数型
.参数 YRGF, 整数型
.局部变量 临时变量, 整数型

临时变量 = 内存操作.读整数 (SDWW + 140)
.如果真 (临时变量 = YRGF 且 SDWW ≠ 内存操作.读代码 (#人物基址))
    .如果真 (HRRE = -1)
        返回 (1)
    .如果真结束
    .如果真 (内存操作.读整数 (SDWW + 1600) = HRRE)
        返回 (1)
    .如果真结束

.如果真结束
返回 (0)
发表于 2013-2-13 18:39:09 | 显示全部楼层
123333333333333333333
发表于 2013-2-13 18:56:17 | 显示全部楼层
..........
发表于 2013-2-13 19:02:45 | 显示全部楼层
腾讯游戏的反智辅保护来一个总结
发表于 2013-3-15 17:23:46 | 显示全部楼层
看下........................
发表于 2013-3-15 17:45:03 | 显示全部楼层
回复 1# 没有不可能


    版本 2
.子程序 检测
.局部变量 首地址, 整数型
.局部变量 地址1, 整数型
.局部变量 id, 整数型
id = 取进程ID (“DNF.exe”)
首地址 = 十六到十 (“06000000”)
.变量循环首 (首地址, 首地址 + 52428800, 65536, 地址1)
    .如果真 (读内存字节集 (id, 地址1, 4) = { 139, 4, 36, 195 })
        ' MOV eax,dword ptr ds:[esp]
        ' RET
        写内存字节集 (id, 地址1, { 195, 144, 144 })
        ' retn
        ' nop
        ' nop
        跳出循环 ()
    .如果真结束
.变量循环尾 ()
发表于 2013-3-15 17:46:00 | 显示全部楼层
学习学习啊
发表于 2013-3-15 18:18:19 | 显示全部楼层
.................
点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 感恩
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2018-8-19 02:10 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表