易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 48|回复: 0

易语言桌面 易语言怎么取桌面图标啊

[复制链接]
发表于 2017-6-17 09:14:51 | 显示全部楼层 |阅读模式
.版本 2

.子程序 取快捷方式指向文件路径, 文本型, ,
.参数 lnk, 文本型, , lnk 快捷方式的绝对路径
.局部变量 list长度, 整数型
.局部变量 数据, 字节集
.局部变量 文件信息位置, 整数型
.局部变量 文件位置偏移, 整数型
.局部变量 目标路径, 文本型

数据 = 读入文件 (lnk)
.如果真 (数据 = { })
返回 (“”)
.如果真结束
list长度 = 取字节集数据 (数据, #短整数型, 77)
文件信息位置 = list长度 + 78
文件位置偏移 = 取字节集数据 (数据, #整数型, 文件信息位置 + 17)
目标路径 = 取字节集数据 (数据, #文本型, 文件信息位置 + 文件位置偏移 + 1)
返回 (目标路径)

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区  |网站地图

GMT+8, 2017-6-26 01:18 易语言论坛 易语言导航

Powered by 看流星社区 X3.2

©2011-2016 最好的辅助编程技术论坛

快速回复 返回顶部 返回列表