易语言教程_易语言源码_易语言写挂_易语言论坛_看流星社区

 找回密码
 注册
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
零基础辅助入门教学 原创 高清 专业课程售后(每日解答)
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
赞助广告位 请点击这里联系站长 QQ20209081
查看: 469|回复: 1

急急急急急急!!!DNF加密写入 问题!!急急急!!!

[复制链接]
发表于 2014-3-3 01:02:04 | 显示全部楼层 |阅读模式
请教 雨夜大神的加密写入

address1 = 内存_读整数型 (-1, 内存_读整数型 (-1, 十六到十 (#加密参数1)) + 十六到十 (“44”))   这个44  是什么值?

现在随便写个加密写入的辅助  还用到这个44吗   这个44 是不是经常变的?怎么找这个 44  呢?????

下面的代码 这个加密参数1 后面加的这个 44 的值   怎么找这个44呢?

.版本 2

.子程序 加密写入
.参数 地址, 整数型
.参数 数值, 整数型
.局部变量 address1
.局部变量 address2
.局部变量 address3
.局部变量 data1
.局部变量 data2
.局部变量 data3

address1 = 内存_读整数型 (-1, 内存_读整数型 (-1, 十六到十 (#加密参数1)) + 十六到十 (“44”))
address2 = 内存_读整数型 (-1, 十六到十 (#加密参数2))
data1 = 内存_读整数型 (-1, 地址)
data1 = 左移 (data1, 2)
data2 = data1 + address1
data2 = 位异或 (data2, address2)
data3 = 位异或 (data2, 数值)
address3 = data1 + address1
内存_写整数型 (-1, address3, data3)
发表于 2018-12-29 13:11:07 | 显示全部楼层
那那那楠楠安
点击按钮快速添加回复内容: 支持 高兴 激动 给力 加油 苦寻 生气 回帖 路过 感恩
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|看流星社区 |网站地图

GMT+8, 2019-1-22 07:03

Powered by Discuz! X3.4

© 2001-2017 Comsenz Inc.

快速回复 返回顶部 返回列表